logo

Archive for Metasploit

Metasploit su Iphone

Schermata 2011-02-13 a 11.51.25.png

Prima di installare Metasploit sul nostro Iphone è necessario  installare alcuni comandi  (apt, wget, svn) ed alcuni programmi (ruby,rubygems, phyton).

1) Il primo passo è  installare, tramite Cydia, i seguenti comandi:

– APT (APT 0.6 e APT 0.7)

– WGET

2) Fatto questo,  apriamo il Terminale sul Mac e colleghiamoci  all’Iphone:

ssh [email protected] (indirizzo IP dell’Iphone)

e ci spostiamo  sulla seguente directory:

# cd /private/var

installiamo anche Python:

# apt-get install python

e

# apt-get install pyobjc (già che ci siamo…ci servirà poi per SET “Social Engineering Tools”)

3) Le versioni di Ruby (1.9.x) e Rubygems disponibili su Cydia creano degli errori al lancio di msfconsole pertanto, qualora installate, è necessario rimuoverle:

# apt-get remove ruby rubygems

adesso installiamo le versioni precedenti:

#wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/ruby_1.8.6-p111-5_iphoneos-arm.deb

#dpkg -i ruby_1.8.6-p111-5_iphoneos-arm.deb

#wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/rubygems_1.2.0-3_iphoneos-arm.deb

#dpkg -i rubygems_1.2.0-3_iphoneos-arm.deb

#rm ruby*

una volta installate le applicazioni, Cydia ci segnalerà  in “Changes”  la presenza della nuova versione di Ruby che, come già detto, non consente il funzionamento di Metasploit.

4) Installiamo SVN:

# apt-get  install subversion

ed aggiorniamo:# svn update

5) Passiamo ad installare METASPLOIT:
# wget http://www.metasploit.com/releases/framework-3.7.2tar.bz2

# tar jxpf framework-3.7.2tar.bz2

# cd msf3

o

svn co https://www.metasploit.com/svn/framework3/trunk/

6) Per lanciare Metasploit, digitiamo dal terminale dell’Iphone :

# cd /trunk

./msfconsole

I tempi di risposta dell’Iphone non sono certo paragonabili a quelli del Mac, pertanto è necessario dotarsi di un pò di pazienza, in particolare durante l’update.